1. Login to disable the Ads!

Thread offset on page?

Discussion in 'Cars, Coffee and Computers' started by fmorelli, Oct 29, 2017.

  1. fmorelli

    fmorelli Captain

    Not a complaint but a question. Whenever I click on a thread in-flight, the thread indexes to the latest unread message. This is great. But for some reason it indexes too far and cuts off the top of the current response. I have to scroll up to start reading. I'm on the latest Chrome w/Mac.

    Am I the only one? I've attached an example ... this is the URL when I clicked on the thread:
    https://bmw.spoolstreet.com/threads...ly-driver-build-thread.2348/page-2#post-24981

    Thanks!

    Filippo

    Screen Shot 2017-10-29 at 10.55.31 AM.png
     
  2. doublespaces

    doublespaces Administrator

    It happens to me too. I've actually got ten things I'm working on and that is just a little low on my list of priorities. I'm having some oauth2 issues relating to some of the multi site stuff I do, aka https://ford.spoolstreet.com

    Also, been working on a new site, https://www.electrichorizon.com and that has its own armada of bugs and infrastructure hurdles to overcome because I'm using a lot of beta software seeing a high level of churn while I help test software and features from 3rd parties that I intend to use. That site will use cutting edge forum software, newer than what is even here. And once its setup I'll be backporting a bunch of stuff to this site as well... I've got a lot to do.
     
  3. fmorelli

    fmorelli Captain

    I just didn't know if it was something weird about my setup - honestly the forum software here is far beyond better than most that I figured this issue was likely not a bug lol. No worries - thanks ...

    Filippo
     
  4. doublespaces

    doublespaces Administrator

    Would you mind checking this again, I had the jump location modified.
     
  5. fmorelli

    fmorelli Captain

    Well it works but it's really weird. It jumps wrong ... but at the end of the page load, it reindexes the page. If I didn't know any better, the problem wasn't "fixed" ... some tail-end Javascript is getting loading and changing the page location at the end of the load (which is why it jumps back at the end). It's better ... but that's the details. Thanks for addressing this, and I hope my info helps ...

    Filippo
     
  6. doublespaces

    doublespaces Administrator

    I'm not sure if there is a way to anticipate the exact page location because that just depends on how many images/assets are being loaded further up the page. As assets load, the page effectively moves. An alternative may be to simply stay at the top of the page until the page is entirely done loading, however that can be equally as annoying particularly on slow loading pages/devices. When you start to read, then suddenly your screen is yanked away from you off to somewhere else.
     
  7. fmorelli

    fmorelli Captain

    Just FYI - I tested the assets loading idea (I happen to have a slow connection at a hotel in the middle of nowhere), and on this page for instance, no additional assets were loading that were expanding the page. I'm pretty sure that's not causing the bump. The other factor that plays against that - the forum page, regardless of thread, always clips to the same point, then adjusts when the page is complete. It's the same clip which would not be the case if variable assets on the page (above) were loading (say images inline with posts). Nonetheless, if one waits for the page to finish loading, it will ultimately correct itself.

    There is enough JS and what not being loaded on this page that I can't easily say anything more intelligent. Thanks again, though, you've probably wasted too much time on this subject already :)

    Filippo
     
    • Informative Informative x 1
    • List
  8. doublespaces

    doublespaces Administrator

    I appreciate the feedback. I'll see if I can't find a better solution.
     
  9. doublespaces

    doublespaces Administrator

  10. fmorelli

    fmorelli Captain

    Dude it is working like buttah .... perfect ... ok you have to share, what was it?

    Filippo
     
  11. doublespaces

    doublespaces Administrator

    The little bar at the top of the page that shows your name and credits and inbox. That used to float and was actually the part that was interfering as you can see in your original post. I removed the correction and then just disabled the floating of that bar and its fine. I'll have another look later if I decide to float it again.